Talos-Nixos/configuration.nix

62 lines
1.8 KiB
Nix

{ config, lib, pkgs, ... }:
{
imports =
[
./hardware-configuration.nix
./application-configuration.nix
./networking-configuration.nix
];
# Use the systemd-boot EFI boot loader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
# Set your time zone.
time.timeZone = "America/New_York";
users.users.caleb = {
isNormalUser = true;
extraGroups = [ "wheel" ];
openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIHpfoa2RDRJx8SjZgSKdfPauLvxgzJ8rR8l6Yb80A1T7 caleb@surface"
];
};
environment.systemPackages = with pkgs; [
wget
git
screen
];
# disable sudo password for wheel
security.sudo.wheelNeedsPassword = false;
# Enable the OpenSSH daemon.
services.openssh.enable = true;
#neovim
programs.neovim = {
enable = true;
defaultEditor = true;
viAlias = true;
vimAlias = true;
};
# and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
#
# Most users should NEVER change this value after the initial install, for any reason,
# even if you've upgraded your system to a new NixOS release.
#
# This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
# so changing it will NOT upgrade your system.
#
# This value being lower than the current NixOS release does NOT mean your system is
# out of date, out of support, or vulnerable.
#
# Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
# and migrated your data accordingly.
#
# For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
system.stateVersion = "23.11"; # Did you read the comment?
}