Surface-Nixos/networking-configuration.nix

21 lines
497 B
Nix

{ pkgs, ... }:
{
# Enable networking and bluetooth
networking = {
hostName = "surface";
networkmanager = {
enable = true;
wifi.macAddress = "random";
};
};
systemd.services.NetworkManager-wait-online.enable = false; #disable wait online since it is broken
hardware.bluetooth.enable = true;
# Enable mullvad vpn
services.mullvad-vpn.package = pkgs.mullvad-vpn;
services.mullvad-vpn.enable = true;
# Enable tailscale
services.tailscale.enable = true;
}