Surface-Nixos/bootloader-configuration.nix
2024-01-29 23:07:13 -05:00

31 lines
567 B
Nix

{ ... }:
{
# Grub bootloader
boot.loader = {
timeout = 0;
efi.canTouchEfiVariables = true;
grub = {
enable = true;
efiSupport = true;
default = "saved";
device = "nodev";
splashImage = null;
extraConfig = ''set timeout_style=hidden'';
# other menu entries
extraEntries =
''menuentry "System shutdown" {
halt
}
menuentry "System restart" {
reboot
}
menuentry 'UEFI Firmware Settings' --id 'uefi-firmware' {
fwsetup
}'';
};
};
}