January-Nixos/configuration.nix
2024-03-15 22:43:08 -04:00

132 lines
3.4 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ config, lib, pkgs, ... }:
{
imports =
[
./hardware-configuration.nix
./application-configuration.nix
./bluebubbles-configuration.nix
];
# Allow unfree and insecure packages
nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
"steam"
"steam-original"
"steam-run"
"intel-ocl"
];
# Bootloader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
networking.hostName = "january";
# AMD GPU
boot.initrd.kernelModules = [ "amdgpu" ];
services.xserver.videoDrivers = [ "amdgpu" ];
hardware.opengl.extraPackages = with pkgs; [
rocmPackages.clr.icd
intel-ocl
];
environment.variables = {
ROC_ENABLE_PRE_VEGA = "1";
};
# Enable networking
networking.networkmanager.enable = true;
# Set your time zone.
time.timeZone = "America/New_York";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
i18n.extraLocaleSettings = {
LC_ADDRESS = "en_US.UTF-8";
LC_IDENTIFICATION = "en_US.UTF-8";
LC_MEASUREMENT = "en_US.UTF-8";
LC_MONETARY = "en_US.UTF-8";
LC_NAME = "en_US.UTF-8";
LC_NUMERIC = "en_US.UTF-8";
LC_PAPER = "en_US.UTF-8";
LC_TELEPHONE = "en_US.UTF-8";
LC_TIME = "en_US.UTF-8";
};
# Enable the KDE Plasma Desktop Environment.
services.xserver = {
enable = true;
displayManager.sddm.enable = true;
desktopManager.plasma5.enable = true;
};
# Enable sound with pipewire.
sound.enable = true;
hardware.pulseaudio.enable = false;
security.rtkit.enable = true;
services.pipewire = {
enable = true;
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
jack.enable = true;
};
# add unpriveledged user to trusted users
nix.settings.trusted-users = [ "nixremote" ];
# Define a user account. Don't forget to set a password with passwd.
users.users.caleb = {
isNormalUser = true;
description = "caleb";
extraGroups = [ "networkmanager" "wheel" "docker" "video" ];
hashedPassword = "$y$j9T$Xl/nIclFRPpaBoZaGleE1/$GlbK09nmyesJPtoeK/wH2RAhrGnFsEjGVjSVS22ZTn1";
openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIt0GiBYIY4CxoHxOcHWJYE9/cDD88ufLB82LZCkW4T9 caleb@surface"
];
};
# disable sudo password for wheel
security.sudo.wheelNeedsPassword = false;
# List packages installed in system profile. To search, run:
environment.systemPackages = with pkgs; [
git
protontricks
steam-run
wget
winetricks
wineWowPackages.stable
];
# Enable the OpenSSH daemon.
services.openssh = {
enable = true;
settings = {
PasswordAuthentication = false;
KbdInteractiveAuthentication = false;
X11Forwarding = true;
};
};
# Enable wake on lan
networking.interfaces.enp37s0.wakeOnLan.enable = true;
# neovim
programs.neovim = {
enable = true;
defaultEditor = true;
viAlias = true;
vimAlias = true;
};
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. Its perfectly fine and recommended to leave
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = "23.11"; # Did you read the comment?
}